Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Mar 2017
    Posts
    3

    Kompressor problem.....

    Hello everyone, my name is Emiliano, I'm Italian and I live in Rome, I recently bought a c200 Kompressor 1996 in perfect condition, 156000km, this model has 132kw and no variable valve timing. To increase the power I relocated the maf, fpr 4 bar and pulley 220mm. Unfortunately I had problems before the ECU peeling off the compressor beyond 4000, so I connected a zener diode 4.7V to maf and the car was fine but just pushed beyond 4500. Today I did a test, I unplugged the zener diode and connected to a tester, the car before was wrong then suddenly attacked the compressor, the values ​​came to 5.1 and after that did not work more good, the maf (which was new) gave incorrect values. Possible that the pressure peak has broken the maf?

  2. #2
    Junior Member
    Join Date
    Mar 2017
    Posts
    3
    Someone know maf for high flow, I want replace my maf for a model that can read more air flow.

  3. #3
    Senior Member
    Join Date
    May 2013
    Location
    Durban South Africa
    Posts
    263
    Is it an original Bosch MAF?

  4. #4
    Junior Member
    Join Date
    Mar 2017
    Posts
    3
    No, its not original and its all here the problem.....at the end I buy an original bosch maf and then the car run perfectly, without zener and without problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •